GLSA-200606-14 : GDM: Privilege escalation

This script is Copyright (C) 2006-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-200606-14
(GDM: Privilege escalation)

GDM allows a normal user to access the configuration manager.

Impact :

When the 'face browser' in GDM is enabled, a normal user can use the
'configure login manager' with his/her own password instead of the root
password, and thus gain additional privileges.

Workaround :

There is no known workaround at this time.

See also :

http://bugzilla.gnome.org/show_bug.cgi?id=343476
http://www.gentoo.org/security/en/glsa/glsa-200606-14.xml

Solution :

All GDM users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=gnome-base/gdm-2.8.0.8'

Risk factor :

Low / CVSS Base Score : 3.7
(CVSS2#AV:L/AC:H/Au:N/C:P/I:P/A:P)

Family: Gentoo Local Security Checks

Nessus Plugin ID: 21707 (gentoo_GLSA-200606-14.nasl)

Bugtraq ID:

CVE ID: CVE-2006-2452