GLSA-200606-08 : WordPress: Arbitrary command execution

This script is Copyright (C) 2006-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-200606-08
(WordPress: Arbitrary command execution)

rgod discovered that WordPress insufficiently checks the format of
cached username data.

Impact :

An attacker could exploit this vulnerability to execute arbitrary
commands by sending a specially crafted username. As of Wordpress 2.0.2
the user data cache is disabled by default.

Workaround :

There are no known workarounds at this time.

See also :

http://www.gentoo.org/security/en/glsa/glsa-200606-08.xml

Solution :

All WordPress users should upgrade to the latest available version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=www-apps/wordpress-2.0.3'

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)

Family: Gentoo Local Security Checks

Nessus Plugin ID: 21681 (gentoo_GLSA-200606-08.nasl)

Bugtraq ID:

CVE ID: CVE-2006-2667
CVE-2006-2702