GLSA-200606-04 : Tor: Several vulnerabilities

This script is Copyright (C) 2006-2015 Tenable Network Security, Inc.

Synopsis :

The remote Gentoo host is missing one or more security-related

Description :

The remote host is affected by the vulnerability described in GLSA-200606-04
(Tor: Several vulnerabilities)

Some integer overflows exist when adding elements to the smartlists.
Non-printable characters received from the network are not properly
sanitised before being logged. There are additional unspecified bugs in
the directory server and in the internal circuits.

Impact :

The possible buffer overflow may allow a remote attacker to execute
arbitrary code on the server by sending large inputs. The other
vulnerabilities can lead to a Denial of Service, a lack of logged
information, or some information disclosure.

Workaround :

There is no known workaround at this time.

See also :

Solution :

All Tor users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose net-misc/tor

Risk factor :

Medium / CVSS Base Score : 5.0

Family: Gentoo Local Security Checks

Nessus Plugin ID: 21671 (gentoo_GLSA-200606-04.nasl)

Bugtraq ID:

CVE ID: CVE-2006-0414