GLSA-200605-02 : X.Org: Buffer overflow in XRender extension

This script is Copyright (C) 2006-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-200605-02
(X.Org: Buffer overflow in XRender extension)

X.Org miscalculates the size of a buffer in the XRender extension.

Impact :

An X.Org user could exploit this issue to make the X server
execute arbitrary code with elevated privileges.

Workaround :

There is no known workaround at this time.

See also :

http://www.gentoo.org/security/en/glsa/glsa-200605-02.xml

Solution :

All X.Org users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=x11-base/xorg-x11-6.8.2-r7'

Risk factor :

Low / CVSS Base Score : 2.1
(CVSS2#AV:L/AC:L/Au:N/C:N/I:N/A:P)

Family: Gentoo Local Security Checks

Nessus Plugin ID: 21317 (gentoo_GLSA-200605-02.nasl)

Bugtraq ID:

CVE ID: CVE-2006-1526