GLSA-200604-05 : Doomsday: Format string vulnerability

This script is Copyright (C) 2006-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-200604-05
(Doomsday: Format string vulnerability)

Luigi Auriemma discovered that Doomsday incorrectly implements
formatted printing.

Impact :

A remote attacker could exploit these vulnerabilities to execute
arbitrary code with the rights of the user running the Doomsday server
or client by sending specially crafted strings.

Workaround :

There is no known workaround at this time.

See also :

http://aluigi.altervista.org/adv/doomsdayfs-adv.txt
http://www.gentoo.org/security/en/glsa/glsa-200604-05.xml

Solution :

All Doomsday users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=games-fps/doomsday-1.9.0_beta4'

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)

Family: Gentoo Local Security Checks

Nessus Plugin ID: 21198 (gentoo_GLSA-200604-05.nasl)

Bugtraq ID:

CVE ID: CVE-2006-1618