GLSA-200603-06 : GNU tar: Buffer overflow

This script is Copyright (C) 2006-2015 Tenable Network Security, Inc.

Synopsis :

The remote Gentoo host is missing one or more security-related

Description :

The remote host is affected by the vulnerability described in GLSA-200603-06
(GNU tar: Buffer overflow)

Jim Meyering discovered a flaw in the handling of certain header
fields that could result in a buffer overflow when extracting or
listing the contents of an archive.

Impact :

A remote attacker could construct a malicious tar archive that
could potentially execute arbitrary code with the privileges of the
user running GNU tar.

Workaround :

There is no known workaround at this time.

See also :

Solution :

All GNU tar users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=app-arch/tar-1.15.1-r1'

Risk factor :

Medium / CVSS Base Score : 5.1

Family: Gentoo Local Security Checks

Nessus Plugin ID: 21044 (gentoo_GLSA-200603-06.nasl)

Bugtraq ID:

CVE ID: CVE-2006-0300