GLSA-200602-04 : Xpdf, Poppler: Heap overflow

This script is Copyright (C) 2006-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-200602-04
(Xpdf, Poppler: Heap overflow)

Dirk Mueller has reported a vulnerability in Xpdf. It is caused by
a missing boundary check in the splash rasterizer engine when handling
PDF splash images with overly large dimensions.

Impact :

By sending a specially crafted PDF file to a victim, an attacker
could cause an overflow, potentially resulting in the execution of
arbitrary code with the privileges of the user running the application.

Workaround :

There is no known workaround at this time.

See also :

http://www.gentoo.org/security/en/glsa/glsa-200602-04.xml

Solution :

All Xpdf users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=app-text/xpdf-3.01-r7'
All Poppler users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=app-text/poppler-0.5.0-r4'

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)

Family: Gentoo Local Security Checks

Nessus Plugin ID: 20894 (gentoo_GLSA-200602-04.nasl)

Bugtraq ID:

CVE ID: CVE-2006-0301