GLSA-200601-11 : KDE kjs: URI heap overflow vulnerability

This script is Copyright (C) 2006-2015 Tenable Network Security, Inc.

Synopsis :

The remote Gentoo host is missing one or more security-related

Description :

The remote host is affected by the vulnerability described in GLSA-200601-11
(KDE kjs: URI heap overflow vulnerability)

Maksim Orlovich discovered an incorrect bounds check in kjs when
handling URIs.

Impact :

By enticing a user to load a specially crafted webpage containing
malicious JavaScript, an attacker could execute arbitrary code with the
rights of the user running kjs.

Workaround :

There is no known workaround at this time.

See also :

Solution :

All kdelibs users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose kde-base/kdelibs-3.4.3-r1

Risk factor :

High / CVSS Base Score : 7.5

Family: Gentoo Local Security Checks

Nessus Plugin ID: 20798 (gentoo_GLSA-200601-11.nasl)

Bugtraq ID:

CVE ID: CVE-2006-0019