Ubuntu 4.10 : libxpm4 vulnerability (USN-27-1)

Ubuntu Security Notice (C) 2004-2016 Canonical, Inc. / NASL script (C) 2006-2016 Tenable Network Security, Inc.


Synopsis :

The remote Ubuntu host is missing one or more security-related
patches.

Description :

Chris Evans discovered several stack overflows in the versions of
libXpm shipped by X.Org, XFree86, and LessTif. These overflows were
fixed in the Warty development tree before its release. Mathieu Herrb
of OpenBSD subsequently discovered that the original patch was
insufficient to address these overflows, and thus the version of
libxpm4 shipped with Warty is still vulnerable to the original
overflows.

These overflows do not allow privilege escalation through the X
server
the overflows are in a client-side library, allowing arbitrary
code execution with the privileges of the user viewing a malicious
pixmap.

Note that Tenable Network Security has extracted the preceding
description block directly from the Ubuntu security advisory. Tenable
has attempted to automatically clean and format it as much as possible
without introducing additional issues.

Solution :

Update the affected packages.

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)

Family: Ubuntu Local Security Checks

Nessus Plugin ID: 20642 ()

Bugtraq ID:

CVE ID: CVE-2004-0687
CVE-2004-0688