Ubuntu 4.10 / 5.04 : linux-source-2.6.10, linux-source-2.6.8.1 vulnerabilities (USN-143-1)

Ubuntu Security Notice (C) 2005-2013 Canonical, Inc. / NASL script (C) 2006-2013 Tenable Network Security, Inc.


Synopsis :

The remote Ubuntu host is missing one or more security-related patches.

Description :

A Denial of Service vulnerability has been discovered in the ptrace()
call on the amd64 platform. By calling ptrace() with specially crafted
('non-canonical') addresses, a local attacker could cause the kernel
to crash. This only affects the amd64 platform. (CAN-2005-1762)

ZouNanHai discovered that a local user could hang the kernel by
invoking syscall() with specially crafted arguments. This only affects
the amd64 platform when running in the 32 bit compatibility mode.
(CAN-2005-1765).

Solution :

Update the affected packages.

Risk factor :

Low / CVSS Base Score : 2.1
(CVSS2#AV:L/AC:L/Au:N/C:N/I:N/A:P)

Family: Ubuntu Local Security Checks

Nessus Plugin ID: 20536 ()

Bugtraq ID:

CVE ID: CVE-2005-1762
CVE-2005-1765