GLSA-200601-08 : Blender: Heap-based buffer overflow

This script is Copyright (C) 2006-2015 Tenable Network Security, Inc.

Synopsis :

The remote Gentoo host is missing one or more security-related

Description :

The remote host is affected by the vulnerability described in GLSA-200601-08
(Blender: Heap-based buffer overflow)

Damian Put has reported a flaw due to an integer overflow in the
'get_bhead()' function, leading to a heap overflow when processing
malformed '.blend' files.

Impact :

A remote attacker could entice a user into opening a specially
crafted '.blend' file, resulting in the execution of arbitrary code
with the permissions of the user running Blender.

Workaround :

There is no known workaround at this time.

See also :

Solution :

All Blender users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=media-gfx/blender-2.40'

Risk factor :

High / CVSS Base Score : 7.5

Family: Gentoo Local Security Checks

Nessus Plugin ID: 20418 (gentoo_GLSA-200601-08.nasl)

Bugtraq ID:

CVE ID: CVE-2005-4470