GLSA-200601-03 : HylaFAX: Multiple vulnerabilities

This script is Copyright (C) 2006-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-200601-03
(HylaFAX: Multiple vulnerabilities)

Patrice Fournier discovered that HylaFAX runs the notify script on
untrusted user input. Furthermore, users can log in without a password
when HylaFAX is installed with the pam USE-flag disabled.

Impact :

An attacker could exploit the input validation vulnerability to
run arbitrary code as the user running HylaFAX, which is usually uucp.
The password vulnerability could be exploited to log in without proper
user credentials.

Workaround :

There is no known workaround at this time.

See also :

http://www.hylafax.org/content/HylaFAX_4.2.4_release
http://www.gentoo.org/security/en/glsa/glsa-200601-03.xml

Solution :

All HylaFAX users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=net-misc/hylafax-4.2.3-r1'

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)

Family: Gentoo Local Security Checks

Nessus Plugin ID: 20413 (gentoo_GLSA-200601-03.nasl)

Bugtraq ID:

CVE ID: CVE-2005-3538
CVE-2005-3539