GLSA-200512-11 : CenterICQ: Multiple vulnerabilities

This script is Copyright (C) 2005-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-200512-11
(CenterICQ: Multiple vulnerabilities)

Gentoo developer Wernfried Haas discovered that when the 'Enable
peer-to-peer communications' option is enabled, CenterICQ opens a port
that insufficiently validates whatever is sent to it. Furthermore,
Zone-H Research reported a buffer overflow in the ktools library.

Impact :

A remote attacker could cause a crash of CenterICQ by sending
packets to the peer-to-peer communications port, and potentially cause
the execution of arbitrary code by enticing a CenterICQ user to edit
overly long contact details.

Workaround :

There is no known workaround at this time.

See also :

http://www.zone-h.org/en/advisories/read/id=8480/
http://www.gentoo.org/security/en/glsa/glsa-200512-11.xml

Solution :

All CenterICQ users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=net-im/centericq-4.21.0-r2'

Risk factor :

High / CVSS Base Score : 7.8
(CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C)

Family: Gentoo Local Security Checks

Nessus Plugin ID: 20352 (gentoo_GLSA-200512-11.nasl)

Bugtraq ID:

CVE ID: CVE-2005-3694
CVE-2005-3863