Network Block Device (NBD) Server Request Handling Remote Overflow

This script is Copyright (C) 2005-2013 Tenable Network Security, Inc.


Synopsis :

The remote service is affected by a buffer overflow vulnerability.

Description :

The version of the Network Block Device (NBD) server installed on the
remote host does not properly check the size of read requests before
filling a dynamically-allocated buffer. Using a specially crafted read
request, an attacker can overwrite this buffer, which could crash the
affected server or allow for the execution of arbitrary code.

See also :

http://www.nessus.org/u?d8968f54
http://www.nessus.org/u?7ef06d96

Solution :

Upgrade to NBD 2.8.3 or later.

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 5.5
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: Denial of Service

Nessus Plugin ID: 20341 ()

Bugtraq ID: 16029

CVE ID: CVE-2005-3534