GLSA-200512-05 : Xmail: Privilege escalation through sendmail

This script is Copyright (C) 2005-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-200512-05
(Xmail: Privilege escalation through sendmail)

iDEFENSE reported that the AddressFromAtPtr function in the
sendmail program fails to check bounds on arguments passed from other
functions, and as a result an exploitable stack overflow condition
occurs when specifying the '-t' command line option.

Impact :

A local attacker can make a malicious call to sendmail,
potentially resulting in code execution with elevated privileges.

Workaround :

There is no known workaround at this time.

See also :

http://www.nessus.org/u?7a470ad5
http://www.gentoo.org/security/en/glsa/glsa-200512-05.xml

Solution :

All Xmail users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=mail-mta/xmail-1.22'

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)

Family: Gentoo Local Security Checks

Nessus Plugin ID: 20314 (gentoo_GLSA-200512-05.nasl)

Bugtraq ID:

CVE ID: CVE-2005-2943