GLSA-200510-03 : Uim: Privilege escalation vulnerability

This script is Copyright (C) 2005-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-200510-03
(Uim: Privilege escalation vulnerability)

Masanari Yamamoto discovered that Uim uses environment variables
incorrectly. This bug causes a privilege escalation if setuid/setgid
applications are linked to libuim. This bug only affects
immodule-enabled Qt (if you build Qt 3.3.2 or later versions with
USE='immqt' or USE='immqt-bc').

Impact :

A malicious local user could exploit this vulnerability to execute
arbitrary code with escalated privileges.

Workaround :

There is no known workaround at this time.

See also :

http://lists.freedesktop.org/pipermail/uim/2005-September/001346.html
http://www.gentoo.org/security/en/glsa/glsa-200510-03.xml

Solution :

All Uim users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=app-i18n/uim-0.4.9.1'

Risk factor :

Medium / CVSS Base Score : 4.6
(CVSS2#AV:L/AC:L/Au:N/C:P/I:P/A:P)

Family: Gentoo Local Security Checks

Nessus Plugin ID: 19849 (gentoo_GLSA-200510-03.nasl)

Bugtraq ID:

CVE ID: CVE-2005-3149