Sawmill < 7.1.14 GET Request Query String XSS

This script is Copyright (C) 2005-2016 Tenable Network Security, Inc.


Synopsis :

An application running on the remote web server is affected by a
cross-site scripting vulnerability.

Description :

The version of Sawmill running on the remote web server is affected by
a cross-site scripting vulnerability due to improper validation of
user-supplied input appended to a GET request. An unauthenticated,
remote attacker can exploit this, via a specially crafted request, to
execute arbitrary script code in a user's browser session.

See also :

http://archives.neohapsis.com/archives/bugtraq/2005-09/0114.html
http://www.nessus.org/u?55a77b2f

Solution :

Upgrade to Sawmill version 7.1.14 or later. Alternatively, use Sawmill
in CGI mode.

Risk factor :

Medium / CVSS Base Score : 4.3
(CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N)
CVSS Temporal Score : 3.7
(CVSS2#E:H/RL:OF/RC:C)
Public Exploit Available : true

Family: CGI abuses : XSS

Nessus Plugin ID: 19681 ()

Bugtraq ID: 14789

CVE ID: CVE-2005-2950

Ready to Scan Unlimited IPs & Run Compliance Checks?

Upgrade to Nessus Professional today!

Buy Now

Combine the Power of Nessus with the Ease of Cloud

Start your free Nessus Cloud trial now!

Begin Free Trial