GLSA-200508-09 : bluez-utils: Bluetooth device name validation vulnerability

This script is Copyright (C) 2005-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-200508-09
(bluez-utils: Bluetooth device name validation vulnerability)

The name of a Bluetooth device is improperly validated by the hcid
utility when a remote device attempts to pair itself with a computer.

Impact :

An attacker could create a malicious device name on a Bluetooth
device resulting in arbitrary commands being executed as root upon
attempting to pair the device with the computer.

Workaround :

There are no known workarounds at this time.

See also :

http://www.nessus.org/u?e655d653
http://www.gentoo.org/security/en/glsa/glsa-200508-09.xml

Solution :

All bluez-utils users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=net-wireless/bluez-utils-2.19'

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)

Family: Gentoo Local Security Checks

Nessus Plugin ID: 19442 (gentoo_GLSA-200508-09.nasl)

Bugtraq ID:

CVE ID: CVE-2005-2547