RHEL 4 : kdelibs (RHSA-2005:612)

This script is Copyright (C) 2005-2014 Tenable Network Security, Inc.


Synopsis :

The remote Red Hat host is missing one or more security updates.

Description :

Updated kdelibs packages are now available for Red Hat Enterprise
Linux 4.

This update has been rated as having moderate security impact by the
Red Hat Security Response Team.

kdelibs contains libraries for the K Desktop Environment.

A flaw was discovered affecting Kate, the KDE advanced text editor,
and Kwrite. Depending on system settings, it may be possible for a
local user to read the backup files created by Kate or Kwrite. The
Common Vulnerabilities and Exposures project assigned the name
CVE-2005-1920 to this issue.

Please note this issue does not affect Red Hat Enterprise Linux 3 or
2.1.

Users of Kate or Kwrite should update to these errata packages which
contains a backported patch from the KDE security team correcting this
issue.

See also :

https://www.redhat.com/security/data/cve/CVE-2005-1920.html
http://www.kde.org/info/security/advisory-20050718-1.txt
http://rhn.redhat.com/errata/RHSA-2005-612.html

Solution :

Update the affected kdelibs and / or kdelibs-devel packages.

Risk factor :

Medium / CVSS Base Score : 5.0
(CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N)

Family: Red Hat Local Security Checks

Nessus Plugin ID: 19332 ()

Bugtraq ID:

CVE ID: CVE-2005-1920