GLSA-200507-18 : MediaWiki: Cross-site scripting vulnerability

This script is Copyright (C) 2005-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-200507-18
(MediaWiki: Cross-site scripting vulnerability)

MediaWiki fails to escape a parameter in the page move template
correctly.

Impact :

By enticing a user to visit a specially crafted URL, a remote attacker
could exploit this vulnerability to inject malicious JavaScript code
that will be executed in a user's browser session in the context of the
vulnerable site.

Workaround :

There is no known workaround at this time.

See also :

http://sourceforge.net/project/shownotes.php?release_id=342530
http://www.gentoo.org/security/en/glsa/glsa-200507-18.xml

Solution :

All MediaWiki users should upgrade to the latest available version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=www-apps/mediawiki-1.4.7'

Risk factor :

Medium / CVSS Base Score : 4.3
(CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N)

Family: Gentoo Local Security Checks

Nessus Plugin ID: 19231 (gentoo_GLSA-200507-18.nasl)

Bugtraq ID:

CVE ID: CVE-2005-2396