Slackware 9.0 / current : unzip vulnerability patched (SSA:2003-237-01)

This script is Copyright (C) 2005-2013 Tenable Network Security, Inc.


Synopsis :

The remote Slackware host is missing a security update.

Description :

Upgraded infozip packages are available for Slackware 9.0 and
-current. These fix a security issue where a specially crafted archive
may overwrite files (including system files anywhere on the
filesystem) upon extraction by a user with sufficient permissions.

See also :

http://lwn.net/Articles/38540/
http://www.securityfocus.com/bid/7550
http://xforce.iss.net/xforce/xfdb/12004
http://www.nessus.org/u?f13925b4

Solution :

Update the affected infozip package.

Risk factor :

Low / CVSS Base Score : 2.6
(CVSS2#AV:N/AC:H/Au:N/C:N/I:P/A:N)

Family: Slackware Local Security Checks

Nessus Plugin ID: 18722 ()

Bugtraq ID:

CVE ID: CVE-2003-0282