GLSA-200507-07 : phpWebSite: Multiple vulnerabilities

This script is Copyright (C) 2005-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-200507-07
(phpWebSite: Multiple vulnerabilities)

phpWebSite fails to sanitize input sent to the XML-RPC server
using the 'POST' method. Other unspecified vulnerabilities have been
discovered by Diabolic Crab of Hackers Center.

Impact :

A remote attacker could exploit the XML-RPC vulnerability to
execute arbitrary PHP script code by sending specially crafted XML data
to phpWebSite. The undisclosed vulnerabilities do have an unknown
impact.

Workaround :

There is no known workaround at this time.

See also :

http://www.nessus.org/u?e8f14fb4
http://www.gentoo.org/security/en/glsa/glsa-200507-07.xml

Solution :

All phpWebSite users should upgrade to the latest available
version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=www-app/phpwebsite-0.10.1-r1'

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)
Public Exploit Available : true

Family: Gentoo Local Security Checks

Nessus Plugin ID: 18656 (gentoo_GLSA-200507-07.nasl)

Bugtraq ID:

CVE ID: CVE-2005-1921