MediaWiki 1.4.x < 1.4.6 / 1.5.x < 1.5.0 beta3 Page Move Template XSS

This script is Copyright (C) 2005-2015 Tenable Network Security, Inc.

Synopsis :

The remote web server contains a PHP script that is affected by a
cross-site scripting vulnerability.

Description :

According to its self-reported version number, the installation of
MediaWiki running on the remote host is affected by a cross-site
scripting vulnerability due to a failure to sanitize user-supplied
input passed to the page move template. A remote attacker can exploit
this to inject arbitrary HTML and script code into a user's browser,
resulting in the theft of cookies, misrepresentation of the site, and
other attacks.

See also :

Solution :

Upgrade to MediaWiki 1.4.6 / 1.5.0 beta3 or later.

Risk factor :

Medium / CVSS Base Score : 4.3
CVSS Temporal Score : 3.7
Public Exploit Available : true

Family: CGI abuses : XSS

Nessus Plugin ID: 18644 ()

Bugtraq ID: 14181

CVE ID: CVE-2005-2215