Xerox WorkCentre Multiple Vulnerabilities (XRX05-006)

This script is Copyright (C) 2005-2013 Tenable Network Security, Inc.


Synopsis :

The remote printer suffers from multiple vulnerabilities.

Description :

According to its model number and software version, the remote host
is a Xerox WorkCentre device with an embedded web server that suffers
from multiple flaws, including authentication bypass, denial of
service, unauthorized file access, and cross-site scripting.

See also :

http://www.xerox.com/downloads/usa/en/c/cert_XRX05_006.pdf
http://www.xerox.com/downloads/usa/en/c/cert_XRX05_007.pdf

Solution :

Apply the P22 patch as described in the Xerox security bulletins.

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 6.5
(CVSS2#E:H/RL:OF/RC:C)
Public Exploit Available : true

Family: Misc.

Nessus Plugin ID: 18642 ()

Bugtraq ID: 14187

CVE ID: CVE-2005-2200
CVE-2005-2201
CVE-2005-2202