RHEL 2.1 / 3 / 4 : sudo (RHSA-2005:535)

This script is Copyright (C) 2005-2014 Tenable Network Security, Inc.


Synopsis :

The remote Red Hat host is missing a security update.

Description :

An updated sudo package is available that fixes a race condition in
sudo's pathname validation.

This update has been rated as having moderate security impact by the
Red Hat Security Response Team.

The sudo (superuser do) utility allows system administrators to give
certain users the ability to run commands as root with logging.

A race condition bug was found in the way sudo handles pathnames. It
is possible that a local user with limited sudo access could create a
race condition that would allow the execution of arbitrary commands as
the root user. The Common Vulnerabilities and Exposures project
(cve.mitre.org) has assigned the name CVE-2005-1993 to this issue.

Users of sudo should update to this updated package, which contains a
backported patch and is not vulnerable to this issue.

See also :

https://www.redhat.com/security/data/cve/CVE-2005-1993.html
http://www.securityfocus.com/archive/1/402741/30/0/threaded
http://rhn.redhat.com/errata/RHSA-2005-535.html

Solution :

Update the affected sudo package.

Risk factor :

Low / CVSS Base Score : 3.7
(CVSS2#AV:L/AC:H/Au:N/C:P/I:P/A:P)

Family: Red Hat Local Security Checks

Nessus Plugin ID: 18594 ()

Bugtraq ID:

CVE ID: CVE-2005-1993