GLSA-200506-23 : Clam AntiVirus: Denial of Service vulnerability

This script is Copyright (C) 2005-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-200506-23
(Clam AntiVirus: Denial of Service vulnerability)

Andrew Toller and Stefan Kanthak discovered that a flaw in libmspack's
Quantum archive decompressor renders Clam AntiVirus vulnerable to a
Denial of Service attack.

Impact :

A remote attacker could exploit this vulnerability to cause a Denial of
Service by sending a specially crafted Quantum archive to the server.

Workaround :

There is no known workaround at this time.

See also :

http://sourceforge.net/project/shownotes.php?release_id=337279
http://www.gentoo.org/security/en/glsa/glsa-200506-23.xml

Solution :

All Clam AntiVirus users should upgrade to the latest available
version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=app-antivirus/clamav-0.86.1'

Risk factor :

Low / CVSS Base Score : 2.6
(CVSS2#AV:N/AC:H/Au:N/C:N/I:N/A:P)

Family: Gentoo Local Security Checks

Nessus Plugin ID: 18564 (gentoo_GLSA-200506-23.nasl)

Bugtraq ID:

CVE ID: CVE-2005-2056