GLSA-200506-12 : MediaWiki: Cross-site scripting vulnerability

This script is Copyright (C) 2005-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-200506-12
(MediaWiki: Cross-site scripting vulnerability)

MediaWiki incorrectly handles page template inclusions, rendering
it vulnerable to cross-site scripting attacks.

Impact :

A remote attacker could exploit this vulnerability to inject
malicious script code that will be executed in a user's browser session
in the context of the vulnerable site.

Workaround :

There is no known workaround at this time.

See also :

http://sourceforge.net/project/shownotes.php?release_id=332231
http://www.gentoo.org/security/en/glsa/glsa-200506-12.xml

Solution :

All MediaWiki users should upgrade to the latest available
versions:
# emerge --sync
# emerge --ask --oneshot --verbose www-apps/mediawiki

Risk factor :

Low

Family: Gentoo Local Security Checks

Nessus Plugin ID: 18481 (gentoo_GLSA-200506-12.nasl)

Bugtraq ID:

CVE ID: