GLSA-200506-11 : Gaim: Denial of Service vulnerabilities

This script is Copyright (C) 2005-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-200506-11
(Gaim: Denial of Service vulnerabilities)

Jacopo Ottaviani discovered a vulnerability in the Yahoo! file
transfer code when being offered files with names containing non-ASCII
characters (CAN-2005-1269).
Hugo de Bokkenrijder discovered a
vulnerability when receiving malformed MSN messages (CAN-2005-1934).

Impact :

Both vulnerabilities cause Gaim to crash, resulting in a Denial of
Service.

Workaround :

There are no known workarounds at this time.

See also :

http://gaim.sourceforge.net/security/?id=18
http://gaim.sourceforge.net/security/?id=19
http://www.gentoo.org/security/en/glsa/glsa-200506-11.xml

Solution :

All Gaim users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=net-im/gaim-1.3.1'

Risk factor :

Medium / CVSS Base Score : 5.0
(CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P)

Family: Gentoo Local Security Checks

Nessus Plugin ID: 18468 (gentoo_GLSA-200506-11.nasl)

Bugtraq ID:

CVE ID: CVE-2005-1269
CVE-2005-1934