MediaWiki < 1.3.13 / 1.4.5 / 1.5.0 alpha2 Page Template Inclusions HTML Attributes XSS

This script is Copyright (C) 2005-2015 Tenable Network Security, Inc.

Synopsis :

The remote web server contains a PHP script that is affected by a
cross- site scripting vulnerability.

Description :

According to its self-reported version number, the installation of
MediaWiki running on the remote host is affected by a cross-site
scripting vulnerability due to a failure to sanitize user-supplied
input passed to certain HTML attributes when including a template
inside a style directive when editing an entry. An attacker can
exploit this flaw to inject arbitrary HTML and script code to be
executed by a user's browser within the context of an affected site.

See also :

Solution :

Upgrade to MediaWiki 1.3.13 or later if using 1.3 legacy series

otherwise, upgrade to 1.4.5 or later.

Risk factor :

Medium / CVSS Base Score : 4.3
CVSS Temporal Score : 3.7
Public Exploit Available : true

Family: CGI abuses : XSS

Nessus Plugin ID: 18430 ()

Bugtraq ID: 13861

CVE ID: CVE-2005-1888