GLSA-200504-27 : xine-lib: Two heap overflow vulnerabilities

This script is Copyright (C) 2005-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-200504-27
(xine-lib: Two heap overflow vulnerabilities)

Heap overflows have been found in the code handling RealMedia RTSP
and Microsoft Media Services streams over TCP (MMST).

Impact :

By setting up a malicious server and enticing a user to use its
streaming data, a remote attacker could possibly execute arbitrary code
on the client computer with the permissions of the user running any
multimedia frontend making use of the xine-lib library.

Workaround :

There is no known workaround at this time.

See also :

http://xinehq.de/index.php/security/XSA-2004-8
http://www.gentoo.org/security/en/glsa/glsa-200504-27.xml

Solution :

All xine-lib users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose media-libs/xine-lib

Risk factor :

Medium

Family: Gentoo Local Security Checks

Nessus Plugin ID: 18145 (gentoo_GLSA-200504-27.nasl)

Bugtraq ID:

CVE ID: