GLSA-200504-23 : Kommander: Insecure remote script execution

This script is Copyright (C) 2005-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-200504-23
(Kommander: Insecure remote script execution)

Kommander executes data files from possibly untrusted locations without
user confirmation.

Impact :

An attacker could exploit this to execute arbitrary code with the
permissions of the user running Kommander.

Workaround :

There is no known workaround at this time.

See also :

http://www.kde.org/info/security/advisory-20050420-1.txt
http://www.gentoo.org/security/en/glsa/glsa-200504-23.xml

Solution :

All kdewebdev users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=kde-base/kdewebdev-3.3.2-r2'

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)

Family: Gentoo Local Security Checks

Nessus Plugin ID: 18126 (gentoo_GLSA-200504-23.nasl)

Bugtraq ID:

CVE ID: CVE-2005-0754