RHEL 2.1 / 3 : kdegraphics (RHSA-2005:021)

This script is Copyright (C) 2005-2014 Tenable Network Security, Inc.


Synopsis :

The remote Red Hat host is missing one or more security updates.

Description :

Updated kdegraphics packages that resolve multiple security issues in
kfax are now available.

This update has been rated as having moderate security impact by the
Red Hat Security Response Team

The kdegraphics package contains graphics applications for the K
Desktop Environment.

During a source code audit, Chris Evans discovered a number of integer
overflow bugs that affect libtiff. The kfax application contains a
copy of the libtiff code used for parsing TIFF files and is therefore
affected by these bugs. An attacker who has the ability to trick a
user into opening a malicious TIFF file could cause kfax to crash or
possibly execute arbitrary code. The Common Vulnerabilities and
Exposures project (cve.mitre.org) has assigned the names CVE-2004-0886
and CVE-2004-0804 to these issues.

Additionally, a number of buffer overflow bugs that affect libtiff
have been found. The kfax application contains a copy of the libtiff
code used for parsing TIFF files and is therefore affected by these
bugs. An attacker who has the ability to trick a user into opening a
malicious TIFF file could cause kfax to crash or possibly execute
arbitrary code. The Common Vulnerabilities and Exposures project
(cve.mitre.org) has assigned the name CVE-2004-0803 to this issue.

Users of kfax should upgrade to these updated packages, which contain
backported patches and are not vulnerable to this issue.

See also :

https://www.redhat.com/security/data/cve/CVE-2004-0803.html
https://www.redhat.com/security/data/cve/CVE-2004-0804.html
https://www.redhat.com/security/data/cve/CVE-2004-0886.html
https://www.redhat.com/security/data/cve/CVE-2004-1307.html
https://www.redhat.com/security/data/cve/CVE-2004-1308.html
http://rhn.redhat.com/errata/RHSA-2005-021.html

Solution :

Update the affected kdegraphics and / or kdegraphics-devel packages.

Risk factor :

Critical / CVSS Base Score : 10.0
(CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C)

Family: Red Hat Local Security Checks

Nessus Plugin ID: 18017 ()

Bugtraq ID:

CVE ID: CVE-2004-0803
CVE-2004-0804
CVE-2004-0886
CVE-2004-1307
CVE-2004-1308