MySQL < 4.1.23 / 5.0.42 Access Control Vulnerability

This script is Copyright (C) 2012 Tenable Network Security, Inc.


Synopsis :

The remote database server is affected by an access control
vulnerability.

Description :

The version of MySQL installed on the remote host is older than
4.1.23 or 5.0.42. As such, it reportedly allows a remote,
authenticated user without the DROP privilege to rename arbitrary
tables.

See also :

http://bugs.mysql.com/bug.php?id=27515

Solution :

Upgrade to MySQL version 4.1.23 / 5.0.42 or later.

Risk factor :

Medium / CVSS Base Score : 4.9
(CVSS2#AV:N/AC:M/Au:S/C:N/I:P/A:P)
CVSS Temporal Score : 3.6
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: Databases

Nessus Plugin ID: 17829 ()

Bugtraq ID: 24016

CVE ID: CVE-2007-2691