MySQL < 4.1.13 / 5.0.8 DOS Device Name Denial of Service Vulnerabilities

This script is Copyright (C) 2012 Tenable Network Security, Inc.


Synopsis :

The remote database server may be affected by denial of service
vulnerabilities.

Description :

The version of MySQL installed on the remote host is older than
4.1.13 or 5.0.8.

On Windows, a remote attacker can crash the server via a 'use' command
followed by MS-DOS device name, e.g. LPT1.

See also :

http://marc.info/?l=bugtraq&m=111091250923281&w=2
http://bugs.mysql.com/bug.php?id=9148
http://lists.mysql.com/internals/25190
http://lists.mysql.com/internals/24584
http://archives.neohapsis.com/archives/bugtraq/2005-03/0256.html

Solution :

Upgrade to MySQL version 4.1.13 / 5.0.8 or later.

Risk factor :

Medium / CVSS Base Score : 5.0
(CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P)

Family: Databases

Nessus Plugin ID: 17826 ()

Bugtraq ID:

CVE ID: CVE-2005-0799