MySQL < 4.0.20 File Overwrite

This script is Copyright (C) 2012 Tenable Network Security, Inc.


Synopsis :

Arbitrary files could be overwritten on the remote server.

Description :

The version of MySQL installed on the remote host is older than
4.0.20. A local attacker could exploit a flaw in mysqlbug to overwite
arbitrary files via a symlink attack.

See also :

http://marc.info/?l=bugtraq&m=108206802810402&w=2
http://marc.info/?l=bugtraq&m=108023246916294&w=2

Solution :

Upgrade to MySQL version 4.0.20 or later.

Risk factor :

Low / CVSS Base Score : 2.1
(CVSS2#AV:L/AC:L/Au:N/C:N/I:P/A:N)
CVSS Temporal Score : 1.8
(CVSS2#E:H/RL:OF/RC:C)
Public Exploit Available : true

Family: Databases

Nessus Plugin ID: 17823 ()

Bugtraq ID: 9976

CVE ID: CVE-2004-0381