MySQL < 5.0.51a / 5.1.23 / 6.0.4 Multiple Vulnerabilities

This script is Copyright (C) 2012-2014 Tenable Network Security, Inc.

Synopsis :

The remote database server is affected by multiple vulnerabilities.

Description :

The version of MySQL installed on the remote host is earlier than
5.0.51a / 5.1.23 / 6.0.4 and thus reportedly affected by the following
two vulnerabilities :

- An attacker may be able to cause the the federated
handler and daemon to crash when the federated engine
issues a SHOW TABLE STATUS LIKE query by having a
malicious server return a response with less than
14 columns. (MySQL bug #29801 / CVE-2007-6304)

- It fails to update the DEFINER value of a view when that
is altered, which could allow an authenticated user to
gain additional access through the ALTER VIEW. (MySQL
bug #29908 / CVE-2007-6303)

See also :

Solution :

Upgrade to MySQL version 5.0.51a / 5.1.23 / 6.0.4 or later.

Risk factor :

Medium / CVSS Base Score : 5.0
CVSS Temporal Score : 4.1
Public Exploit Available : true

Family: Databases

Nessus Plugin ID: 17813 ()

Bugtraq ID: 26832

CVE ID: CVE-2007-6303