MySQL < 5.0.89 / 5.1.42 / 5.4.2 / 5.5.1 / 6.0.14 Client XSS

This script is Copyright (C) 2012-2014 Tenable Network Security, Inc.


Synopsis :

A remote database client have a cross-site scripting
vulnerability.

Description :

The version of MySQL installed on the remote host is earlier than
5.0.89 / 5.1.42 / 5.4.2 / 5.5.1 / 6.0.14 and thus does not properly
encode angle brackets when 'mysql --html' option is used. Depending
on how the output of the mysql client command is processed, the user
may be vulnerable to cross-site scripting attacks.

See also :

http://bugs.mysql.com/bug.php?id=27884

Solution :

Upgrade to MySQL version 5.0.89 / 5.1.42 / 5.4.2 / 5.5.1 / 6.0.14 or
later.

Risk factor :

Low / CVSS Base Score : 2.6
(CVSS2#AV:N/AC:H/Au:N/C:N/I:P/A:N)
CVSS Temporal Score : 2.1
(CVSS2#E:F/RL:OF/RC:C)
Public Exploit Available : true

Family: Databases

Nessus Plugin ID: 17811 ()

Bugtraq ID: 31486

CVE ID: CVE-2008-4456