MySQL < 5.0.25 / 5.1.12 Privilege Escalation

This script is Copyright (C) 2012 Tenable Network Security, Inc.


Synopsis :

The remote database server may allow a remote user access to objects
for which he does not have permissions.

Description :

The version of MySQL installed on the remote host is earlier than
5.0.25 / 5.1.12 and thus reportedly allows a remote, authenticated
user to gain privileges through a stored routine.

See also :

http://dev.mysql.com/doc/refman/5.0/en/news-5-0-25.html
http://bugs.mysql.com/bug.php?id=18630

Solution :

Upgrade to MySQL version 5.0.25 / 5.1.12 or later.

Risk factor :

Medium / CVSS Base Score : 6.5
(CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:P)
CVSS Temporal Score : 5.1
(CVSS2#E:POC/RL:OF/RC:C)
Public Exploit Available : true

Family: Databases

Nessus Plugin ID: 17808 ()

Bugtraq ID: 19559

CVE ID: CVE-2006-4227