MySQL < 4.1.21 / 5.0.25 / 5.1.12 Access Control

This script is Copyright (C) 2012 Tenable Network Security, Inc.


Synopsis :

The remote database server may allow a remote user access to a
database for which he does not have permissions.

Description :

The version of MySQL installed on the remote host is earlier than
4.1.21 / 5.0.25 / 5.1.12 and thus reportedly allows a remote user who
has access rights on one database to access another database if the
names differ only in case.

See also :

http://dev.mysql.com/doc/refman/5.0/en/news-5-0-25.html
http://bugs.mysql.com/bug.php?id=17647

Solution :

Upgrade to MySQL version 4.1.21 / 5.0.25 / 5.1.12 or later.

Risk factor :

Low / CVSS Base Score : 3.6
(CVSS2#AV:N/AC:H/Au:S/C:P/I:P/A:N)
CVSS Temporal Score : 2.8
(CVSS2#E:POC/RL:OF/RC:C)
Public Exploit Available : true

Family: Databases

Nessus Plugin ID: 17807 ()

Bugtraq ID: 19559

CVE ID: CVE-2006-4226