MySQL < 4.1.20 / 5.0.22 / 5.1.11 SQL Injection

This script is Copyright (C) 2012 Tenable Network Security, Inc.


Synopsis :

The remote database server is vulnerable to a SQL injection
attack.

Description :

The version of MySQL installed on the remote host is earlier than
4.1.20 / 5.0.22 / 5.1.11 and thus reportedly allows a remote attack to
launch SQL injections by using multibyte character encodings (e.g.
SJIS, BIG5, GBK) when mysql_real_escape is used.

See also :

http://lists.mysql.com/announce/364

Solution :

Upgrade to MySQL version 4.1.20 / 5.0.22 / 5.1.11 or later.

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 6.2
(CVSS2#E:F/RL:OF/RC:C)
Public Exploit Available : true

Family: Databases

Nessus Plugin ID: 17806 ()

Bugtraq ID: 18219

CVE ID: CVE-2006-2753