MySQL < 4.1.12 / 5.0.4 Insecure Permissions

This script is Copyright (C) 2012-2013 Tenable Network Security, Inc.


Synopsis :

Arbitrary SQL commands may be run on the remote database server.

Description :

The remote MySQL server is earlier than 4.1.12 / 5.0.4 and thus
reportedly creates a temporary file with insecure permissions and a
predictable name, which could allow a local user to run arbitrary SQL
commands.

See also :

http://marc.info/?l=full-disclosure&m=111632686805498&w=2

Solution :

Upgrade to MySQL version 4.1.12 / 5.0.4 or later.

Risk factor :

Medium / CVSS Base Score : 4.6
(CVSS2#AV:L/AC:L/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 4.0
(CVSS2#E:H/RL:OF/RC:ND)
Public Exploit Available : true

Family: Databases

Nessus Plugin ID: 17805 ()

Bugtraq ID: 13660

CVE ID: CVE-2005-1636