MySQL < 4.1.21 / 5.0.24 Privilege Persistence

This script is Copyright (C) 2012-2016 Tenable Network Security, Inc.


Synopsis :

The remote database server allows a local user to access unauthorized
data.

Description :

The version of MySQL installed on the remote host is earlier than
4.1.21 / 5.0.24 and thus reportedly allows a local user to access a
table after his privileges on it were revoked.

See also :

http://dev.mysql.com/doc/refman/4.1/en/news-4-1-21.html
http://dev.mysql.com/doc/refman/5.0/en/news-5-0-24.html

Solution :

Upgrade to MySQL version 5.0.24 or later.

Risk factor :

Low / CVSS Base Score : 2.1
(CVSS2#AV:L/AC:L/Au:N/C:P/I:N/A:N)
CVSS Temporal Score : 1.8
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true

Family: Databases

Nessus Plugin ID: 17802 ()

Bugtraq ID: 19279

CVE ID: CVE-2006-4031

Ready to Scan Unlimited IPs & Run Compliance Checks?

Upgrade to Nessus Professional today!

Buy Now

Combine the Power of Nessus with the Ease of Cloud

Start your free Nessus Cloud trial now!

Begin Free Trial