MySQL < 5.0.22 / 5.1.10 Authentication Bypass

This script is Copyright (C) 2012 Tenable Network Security, Inc.


Synopsis :

The remote database server is vulnerable to an authentication bypass
attack.

Description :

The version of MySQL installed on the remote host is earlier than
5.0.22 / 5.1.10 and thus reportedly allows a local user to bypass
authentication by sending a SQL query that contains a NULL
character.

See also :

http://bugs.mysql.com/bug.php?id=17667

Solution :

Upgrade to MySQL version 5.0.22 / 5.1.10 or later.

Risk factor :

Medium / CVSS Base Score : 4.6
(CVSS2#AV:L/AC:L/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 3.8
(CVSS2#E:F/RL:OF/RC:ND)
Public Exploit Available : true

Family: Databases

Nessus Plugin ID: 17801 ()

Bugtraq ID: 16850

CVE ID: CVE-2006-0903