OpenSSL < 0.9.8p / 1.0.0b Buffer Overflow

This script is Copyright (C) 2012-2016 Tenable Network Security, Inc.

Synopsis :

The remote server is affected by a buffer overflow vulnerability.

Description :

According to its banner, the remote server is running a version of
OpenSSL that is earlier than 0.9.8p / 1.0.0b.

If a TLS server is multithreaded and uses the SSL cache, a remote
attacker could trigger a buffer overflow and crash the server or run
arbitrary code.

See also :

Solution :

Upgrade to OpenSSL 0.9.8p / 1.0.0b or later.

Risk factor :

High / CVSS Base Score : 7.6
CVSS Temporal Score : 6.6
Public Exploit Available : false

Family: Web Servers

Nessus Plugin ID: 17766 ()

Bugtraq ID: 44884

CVE ID: CVE-2010-3864

Ready to Scan Unlimited IPs & Run Compliance Checks?

Upgrade to Nessus Professional today!

Buy Now

Combine the Power of Nessus with the Ease of Cloud

Start your free Nessus Cloud trial now!

Begin Free Trial