OpenSSL < 0.9.8l Multiple Vulnerabilities

This script is Copyright (C) 2012-2014 Tenable Network Security, Inc.


Synopsis :

The remote server is affected by multiple vulnerabilities.

Description :

According to its banner, the remote server is running a version of
OpenSSL that is earlier than 0.9.8l. As such, it may be affected by
multiple vulnerabilities :

- A remote attacker could crash the server by sending
malformed ASN.1 data. This flaw only affects some
architectures, Win64 and other unspecified platforms.
(CVE-2009-0789)

- A remote attacker could saturate the server by sending
a big number of 'future epoch' DTLS records.
(CVE-2009-1377)

- A remote attacker could saturate the server by sending
duplicate DTLS records, or DTLS records with too big
sequence numbers. (CVE-2009-1378)

- A remote attacker could spoof certificates by computing
MD2 hash collisions. (CVE-2009-2409)

See also :

http://voodoo-circle.sourceforge.net/sa/sa-20090326-01.html
http://www.openssl.org/news/secadv_20090325.txt
http://voodoo-circle.sourceforge.net/sa/sa-20091012-01.html
http://rt.openssl.org/Ticket/Display.html?id=1930&user=guest&pass=guest
http://rt.openssl.org/Ticket/Display.html?id=1931&user=guest&pass=guest
http://cvs.openssl.org/chngview?cn=18187
http://cvs.openssl.org/chngview?cn=18188

Solution :

Upgrade to OpenSSL 0.9.8l or later.

Risk factor :

Medium / CVSS Base Score : 5.1
(CVSS2#AV:N/AC:H/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 4.0
(CVSS2#E:POC/RL:OF/RC:C)
Public Exploit Available : true

Family: Web Servers

Nessus Plugin ID: 17765 ()

Bugtraq ID: 34256
35001

CVE ID: CVE-2009-0789
CVE-2009-1377
CVE-2009-1378
CVE-2009-2409