OpenSSL < 0.9.8j Signature Spoofing

This script is Copyright (C) 2012-2014 Tenable Network Security, Inc.


Synopsis :

The remote server is affected by a signature validation bypass
vulnerability.

Description :

According to its banner, the remote server is running a version of
OpenSSL that is earlier than 0.9.8j.

A remote attacker could implement a man-in-the-middle attack by
forging an SSL/TLS signature using DSA and ECDSA keys which bypass
validation of the certificate chain.

See also :

http://www.us-cert.gov/cas/techalerts/TA09-133A.html

Solution :

Upgrade to OpenSSL 0.9.8j or later.

Risk factor :

Medium / CVSS Base Score : 5.8
(CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:P)
CVSS Temporal Score : 4.8
(CVSS2#E:F/RL:OF/RC:C)
Public Exploit Available : true

Family: Web Servers

Nessus Plugin ID: 17762 ()

Bugtraq ID: 33150

CVE ID: CVE-2008-5077