OpenSSL < 0.9.8i Denial of Service

This script is Copyright (C) 2012-2014 Tenable Network Security, Inc.


Synopsis :

The remote server is affected by a denial of service
vulnerability.

Description :

According to its banner, the remote server is running a version of
OpenSSL that is earlier than 0.9.8i.

A remote attacker can crash the server by sending a DTLS
ChangeCipherSpec packet before the ClientHello.

See also :

http://cvs.openssl.org/chngview?cn=17369
http://rt.openssl.org/Ticket/Display.html?id=1679&user=guest&pass=guest

Solution :

Upgrade to OpenSSL 0.9.8i or later.

Risk factor :

Medium / CVSS Base Score : 5.0
(CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P)
CVSS Temporal Score : 4.1
(CVSS2#E:F/RL:OF/RC:C)
Public Exploit Available : true

Family: Web Servers

Nessus Plugin ID: 17761 ()

Bugtraq ID: 35174

CVE ID: CVE-2009-1386