OpenSSL < 0.9.7m / 0.9.8e Buffer Overflow

This script is Copyright (C) 2012-2014 Tenable Network Security, Inc.


Synopsis :

The remote server is affected by an unspecified buffer overflow
vulnerability.

Description :

According to its banner, the remote server is running a version of
OpenSSL that is earlier than 0.9.7m or 0.9.8e.

A remote attacker could trigger a one-byte buffer overflow. The real
impact is unknown. Arbitrary code could be run but no functional
exploit was published.

See also :

http://www.openssl.org/news/secadv_20071012.txt
http://www.securityfocus.com/archive/1/archive/1/480855/100/0/threaded
http://www.openssl.org/news/secadv_20071012.txt

Solution :

Upgrade to OpenSSL 0.9.7m / 0.9.8e or later.

Risk factor :

Medium / CVSS Base Score : 6.8
(CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 5.0
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: Web Servers

Nessus Plugin ID: 17758 ()

Bugtraq ID: 25831

CVE ID: CVE-2007-5135