OpenSSL < 0.9.7k / 0.9.8c PKCS Padding RSA Signature Forgery Vulnerability

This script is Copyright (C) 2012-2015 Tenable Network Security, Inc.

Synopsis :

The SSL layer on the remote server does not properly verify

Description :

According to its banner, the remote server is running a version of
OpenSSL that is earlier than 0.9.7k or 0.9.8c.

These versions do not properly verify PKCS #1 v1.5 signatures and X509
certificates when the RSA exponent is 3.

See also :

Solution :

Upgrade to OpenSSL 0.9.7k / 0.9.8c or later.

Risk factor :

Medium / CVSS Base Score : 4.3
CVSS Temporal Score : 3.6
Public Exploit Available : true

Family: Web Servers

Nessus Plugin ID: 17756 ()

Bugtraq ID: 19849

CVE ID: CVE-2006-4339