OpenSSL < 0.9.7f Insecure Temporary File Creation

This script is Copyright (C) 2012-2014 Tenable Network Security, Inc.


Synopsis :

Arbitrary files could be overwritten on the remote server.

Description :

According to its banner, the remote server is running a version of
OpenSSL that is earlier than 0.9.7f.

The der_shop script that is shipped with these versions allows a
malicious user to overwrite arbitrary files.

Note that this was fixed in the 0.9.6 CVS but no new version was
published in the 0.9.6 branch.

See also :

http://www.openssl.org/news/vulnerabilities.html#2004-0975

Solution :

Upgrade to OpenSSL 0.9.7f or later.

Risk factor :

Low / CVSS Base Score : 2.1
(CVSS2#AV:L/AC:L/Au:N/C:N/I:P/A:N)
CVSS Temporal Score : 1.8
(CVSS2#E:H/RL:OF/RC:C)
Public Exploit Available : true

Family: Web Servers

Nessus Plugin ID: 17754 ()

Bugtraq ID: 11293

CVE ID: CVE-2004-0975